Connecting to ShapeWays


#1

Hi there, this post explains how to enable the ShapeWays bridge on your Grasshopper models.

  1. Register for an account on ShapeWays.

  2. Create a new app in the My Apps section of your ShapeWays account, for the ShapeDiver-ShapeWays bridge.

  3. Create OAuth2 credentials for your app:

  4. Use the ShapeDiverShapeWaysCredentials component of the ShapeDiver Grasshopper plug-in to define the credentials needed for accessing your ShapeWays account.

  5. Use the ShapeDiverExportShapeWays component to define the product data you want to send to ShapeWays. Connect the API credentials to the CR parameter.

  1. Optionally use the further components which retrieve data from the ShapeWays API, e.g. for requesting available materials, price estimation, categories, and printers. We recommend you to limit use of these components for models which you upload to ShapeDiver and instead hard-code information about materials and categories into your Grasshopper model. This will minimise the model computation time and improve user experience.

  2. That’s it! Upload your Grasshopper model to ShapeDiver, and start selling products. The export component will appear as a button in the parameter widget, rename the component to your liking.


#2

Hi,
I try to export to shapeways with this instructions but stucked up at step 7. After uploding definition with shapediverexportshapeways component it works in shapediver environment, but the export button on parameter widget in ShapeDiver didn’t work. After clicking and wait for processing, I got this massage: “No exported model data found for upload to ShapeWays”.


#3

Please make sure to only feed meshes into the ShapeDiverExportShapeWays component. In case your model consists of NURBS, please use Grasshopper’s Mesh Brep component to mesh it. We do not automatically mesh NURBS in this case on purpose. Use the Settings (Custom) component of Grasshopper to control the quality of the resulting mesh.

For the moment our ShapeDiverExportShapeWays component does not give you a warning if you feed something else than a mesh into it, this will be improved.


#4

Thanks, it works now.
I suggest you to rename input parametar “G” into “M”, with the description “The closed mesh to be exported” (instead of “The geometry to be exported”) ,for the component “ShapeDiverExportShapeWays”. In that way, Grasshopper users will know that it works only for meshes.


#5

Is it possible to export to shapeways as a customizable model, with the widget parameters as in ShapeDiver?


#6

Many thanks for this hint, great idea! We will change the description with next release, the name of the parameter must stay the same for compatibility reasons.


#7

Do you mean whether it is possible to export a customizable model to ShapeWays, such that it can still be modified on ShapeWays? This is not supported by ShapeWays.


#8

Hello Alex,

I apologize if I skipped some important announcements, I was busy in the previous weeks, but it seems that I don’t have the latest version of the ShapeDiver. I am missing all of the functions concerning connection with ShapeWays: ShapeDiverShapeWaysCredentials and ShapeDiverExportShapeWays.

If you have send it through e-mail, could you please resend it or please refer me to the link where I can download it? I tried yesterday and today with downloading the latest ShapeDiver I could find, but there are no new functions there either.

Thank you very much!


#9

The ShapeWays components are not yet publicly available, we will add you to the list of beta testers and sent the update to you directly.


#10

Alex,

thank you for quick response and for adding me to the list.

Best!


#11

Hi Alex, Could you add me to the list as well? I really enjoy how my object seems in shapediver. Lets see in Shapeways too.


#12

Sure, you will receive an email containing instructions.


#13

Hi, i followed the tread step by step and i´m unable to connect my Shapediver account with ShapeWays.

I don´t know what to do.
Can you help me.

Thanks


#14

It seems like there is different version of the Newtonsoft.JSON library being used than the one we provided. We will send you another download link, please make sure to copy all the files into your Grasshopper components directory and try again.


#15

Hi, i download and install the new version of the plug in in the Morning, and worked perfectly.
But now it doesn´t work. I reinstall it and didn´t work.


#16

This looks like exactly the same problem again. Maybe you have a second copy of the ShapeDiverForGrasshopper.gha file somewhere on your disk? In this case Grasshopper might load it from an unwanted location and then not find the Newtonsoft.Json.dll or one of the other dependent DLLs that are contained in the zip file you received. Please check whether you have a further copy of ShapeDiverForGrasshopper.gha somewhere.


#17

Ok, i,ll Check it out Thanks


#18

I erase all the instances of the Newtonsoft in the grasshopper files and it works.

Now when i click the Print 3d button sends me an error.
Any suggestions??


#19

I just checked our logs. The ShapeWays API denied due to this reason: "Field ‘defaultMaterialId’ cannot be set to 40. You may not have the permissions needed to use this material."
As an example, if in your model you change to “Gloss blue porcelain” it works (but interestingly ShapeWays then shows me “Stainless Steel”, maybe you mixed up the material ids in your GH model?)


#20

I have an error in the materials id.
Thank You

I think it works.
But textures doesn’t look very appealing.
Try it…

https://www.shapediver.com/m/calcium-twist-from-a-shot-to-cup